JoinDomain VMExtensionProvisioningError when deploying WVD (aka Conflict Error)

Deploying WVD Fails with a conflict error and when clicking for more information it presents a conflict and not much else that is useful by way of toubleshooting. Hopefully this helps someone else as it had me head scratching for a little while.. When creating the Host Pool, make sure that you haven't made the fatal error of using the Azure Active Directory Credential INSTEAD of the Local AD Domain Credential.  i.e do not use USER@m365xxxxx.onmicrosoft.com to domain join, even if it links back to the domain - this is where the conflict arrises.    Instead, use your full internal domain UPN.  USER@prefix.domain.co.uk  Re-deploy your same configuration and you should find it goes through now without any problems. Additional findings.... Albeit my mistake above was an easy one, it does appear the error is directly linked to the domain join process. If you go into your resource groups, locate the session host and MSTSC directly to it.  Try the domain join pr

Outlook 2007 asks for a password everytime you open it

Scenario: SBS 2008
TS 2K3 - 30 users
Outlook 2007


Problem
OK, so to save a lot of people a lot of time!

I spent ages trying to diagnose this issue, we had 30 people all getting this message asking for a username and password whenever they opened outlook. I also noticed that if we setup a new user we had difficulty even getting it setup as autodiscovery seemed to keep failing.

Resolution
Weirdly enough I think it's linked to an update on SBS2008 Ex2007. Check your Exchange to see what rollup it's running (Under Server Configuration - Build No.) You should update it to Rollup V.9 if it isnt already which seems to clear the issue.

Link:
http://www.microsoft.com/downloads/details.aspx?FamilyID=55320be2-c65c-48bb-bab8-6335aa7d008c&displaylang=en

NOTE
A quick note to some people - when you download the rollup and try to install it you'll probably find you can't due to privelidges. I got it to work by opening CMD with run as administrator, renamed the setup to Exchange then just run exchange.msp in the cmd box.

Comments

Popular posts from this blog

This product type does not match the list of supported product types

SBS 2008 hangs on Applying Computer Settings

LSASS.EXE - System Error / Rebuilding Active Directory Indices. When booting windows server 2003